package/gstreamer1/gst1-plugins-bad: add audiolatency plugin option
authorAdam Duskett <Aduskett@gmail.com>
Thu, 9 May 2019 22:46:22 +0000 (18:46 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 May 2019 19:20:01 +0000 (21:20 +0200)
This plugin was introduced in 1.16.0. It is dependencyless and
provides a way to measure audio latency.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index c53ff662726e4689d5214b8210a99e82ffa4a8e2..35d6bddd05cf6801c73c4811cccf2f13c7105a6f 100644 (file)
@@ -46,6 +46,11 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOFXBAD
        help
          Audio filters plugin
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOLATENCY
+       bool "audiolatency"
+       help
+         Audio latency plugin
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOMIXMATRIX
        bool "audiomixmatrix"
        help
index d6414f9daa8e0de3fa6d7c3f3ab4240700172159..ad1adbc3850161efc563b0baad537ea987bd9740 100644 (file)
@@ -132,6 +132,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-audiofxbad
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOLATENCY),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-audiolatency
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-audiolatency
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOMIXMATRIX),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-audiomixmatrix
 else