package/gcc/mpfr: remove deprecated features
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 1 Dec 2014 14:16:58 +0000 (11:16 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 19:05:59 +0000 (20:05 +0100)
Remove the fortran and objective C language support since these have
been deprecated since more than a year ago.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/Config.in.host
package/gcc/gcc-final/gcc-final.mk
package/mpfr/Config.in

index 3bccf3646cf5e568125ce75cc855d8f488e6d1be..9d08ccbbfd89a695078ceae3f53e007d0728d415 100644 (file)
@@ -118,25 +118,6 @@ config BR2_TOOLCHAIN_BUILDROOT_CXX
 comment "C++ support broken in uClibc with locale enabled with gcc 4.2"
        depends on BR2_GCC_VERSION_4_2_2_AVR32_2_1_5 && BR2_TOOLCHAIN_BUILDROOT_LOCALE
 
-config BR2_INSTALL_OBJC
-       bool "Enable Objective-C support"
-       depends on !BR2_avr32
-       depends on BR2_DEPRECATED_SINCE_2013_11
-       help
-         Enable the support for the Objective-C language in the
-         cross-compiler, and install the Objective-C runtime to the
-         target.
-
-config BR2_INSTALL_FORTRAN
-       bool "Enable Fortran support"
-       depends on !BR2_avr32
-       depends on BR2_DEPRECATED_SINCE_2013_11
-       select BR2_PACKAGE_LIBMPFR
-       help
-         Enable the support for the Fortran language in the
-         cross-compiler, and install the Fortran runtime to the
-         target.
-
 config BR2_GCC_ENABLE_TLS
        bool "Enable compiler tls support" if BR2_TOOLCHAIN_BUILDROOT_UCLIBC
        default y
index 9579b6350744ef33f2a3c3d0c483968a33999af0..46ef5c6bc045527d14052ad5dff90a13ee95f760 100644 (file)
@@ -44,8 +44,6 @@ endef
 # Languages supported by the cross-compiler
 GCC_FINAL_CROSS_LANGUAGES-y = c
 GCC_FINAL_CROSS_LANGUAGES-$(BR2_INSTALL_LIBSTDCPP) += c++
-GCC_FINAL_CROSS_LANGUAGES-$(BR2_INSTALL_FORTRAN) += fortran
-GCC_FINAL_CROSS_LANGUAGES-$(BR2_INSTALL_OBJC)    += objc
 GCC_FINAL_CROSS_LANGUAGES = $(subst $(space),$(comma),$(GCC_FINAL_CROSS_LANGUAGES-y))
 
 HOST_GCC_FINAL_CONF_OPTS = \
@@ -131,14 +129,6 @@ ifeq ($(BR2_GCC_ENABLE_OPENMP),y)
 HOST_GCC_FINAL_USR_LIBS += libgomp
 endif
 
-ifeq ($(BR2_INSTALL_FORTRAN),y)
-HOST_GCC_FINAL_USR_LIBS += libgfortran
-endif
-
-ifeq ($(BR2_INSTALL_OBJC),y)
-HOST_GCC_FINAL_USR_LIBS += libobjc
-endif
-
 ifeq ($(BR2_GCC_ENABLE_LIBMUDFLAP),y)
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
 HOST_GCC_FINAL_USR_LIBS += libmudflapth
index 9acb0b4bdf0a1888b6b10fb501ce6a32d1430173..e02511f8f130d7e01277f75d02c4ecd2030aee83 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_MPFR
        bool "mpfr"
-       default y if BR2_INSTALL_FORTRAN
        select BR2_PACKAGE_GMP
        help
          C library for multiple-precision floating-point computations