package/pistache: new package
authorThomas Ruschival <thomas@ruschival.de>
Fri, 1 May 2020 09:22:26 +0000 (11:22 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 1 May 2020 12:04:51 +0000 (14:04 +0200)
The upstream project http://pistache.io/ does not provide release
tarballs. However, commit 73f248acd6db4c53 has been successfully
used for some time now.

The use of BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 is for C++14 support.
Tested it with gcc-linaro-4.9-2016.02-x86_64_arm-linux-gnueabi
and buildroot's ./utils/test-pkg

Pistache does not build with uClibc, the macro RUSAGE_THREAD for
getrusage() is not properly declared. This is an upstream issue:
https://github.com/oktal/pistache/issues/175
Hence the dependecy !BR2_TOOLCHAIN_USES_UCLIBC

Signed-off-by: Thomas Ruschival <thomas@ruschival.de>
[yann.morin.1998@free.fr:
  - fix PISTACHE_LICENSE_FILES (missing trailing 'S')
  - add hash for license file
  - two spaces in license file
  - tweaks in commit log
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/Config.in
package/pistache/Config.in [new file with mode: 0644]
package/pistache/pistache.hash [new file with mode: 0644]
package/pistache/pistache.mk [new file with mode: 0644]

index 53c8ce0e29aa563bb40eda3cef7598f8b731b7bc..c12676d85969ab033417fd7477e05888f3804939 100644 (file)
@@ -1754,6 +1754,7 @@ menu "Networking"
        source "package/ortp/Config.in"
        source "package/paho-mqtt-c/Config.in"
        source "package/paho-mqtt-cpp/Config.in"
+       source "package/pistache/Config.in"
        source "package/qdecoder/Config.in"
        source "package/qpid-proton/Config.in"
        source "package/rabbitmq-c/Config.in"
diff --git a/package/pistache/Config.in b/package/pistache/Config.in
new file mode 100644 (file)
index 0000000..64d6340
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_PISTACHE
+       bool "pistache"
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_TOOLCHAIN_USES_UCLIBC
+       help
+         Pistache is a modern and elegant HTTP and REST framework
+         for C++. It is entirely written in pure C++14 and provides
+         a clear and pleasant API.
+
+         https://github.com/oktal/pistache
+
+comment "pistache needs a glibc toolchain w/ C++, gcc >= 4.9, threads, wchar"
+       depends on !BR2_INSTALL_LIBSTDCPP || \
+       BR2_TOOLCHAIN_USES_UCLIBC || \
+       !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
+       !BR2_TOOLCHAIN_HAS_THREADS || \
+       !BR2_USE_WCHAR
diff --git a/package/pistache/pistache.hash b/package/pistache/pistache.hash
new file mode 100644 (file)
index 0000000..63597b4
--- /dev/null
@@ -0,0 +1,3 @@
+#locally computed
+sha256  bcc7640eb4ae4b178e504f18ebf29dd0a6f8189710cdc0fa4703fa27728145e4  pistache-73f248acd6db4c53e6604577b7e13fd5e756f96f.tar.gz
+sha256  c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08  LICENSE
diff --git a/package/pistache/pistache.mk b/package/pistache/pistache.mk
new file mode 100644 (file)
index 0000000..c182754
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# pistache
+#
+################################################################################
+
+PISTACHE_VERSION = 73f248acd6db4c53e6604577b7e13fd5e756f96f
+PISTACHE_SITE = $(call github,oktal,pistache,$(PISTACHE_VERSION))
+PISTACHE_LICENSE = Apache-2.0
+PISTACHE_LICENSE_FILES = LICENSE
+
+PISTACHE_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+PISTACHE_DEPENDENCIES += openssl
+PISTACHE_CONF_OPTS += -DPISTACHE_USE_SSL=ON
+else
+PISTACHE_CONF_OPTS += -DPISTACHE_USE_SSL=OFF
+endif
+
+$(eval $(cmake-package))