openvpn: Add explicit support for external lz4
authorJeroen Roovers <jer@airfi.aero>
Fri, 24 Mar 2017 07:12:03 +0000 (08:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Mar 2017 13:57:17 +0000 (14:57 +0100)
2.4.0 added lz4 support. Make that choice explicit or the bundled compat-lz4
"stub" will be used.

Signed-off-by: Jeroen Roovers <jer@airfi.aero>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openvpn/Config.in
package/openvpn/openvpn.mk

index 5fa191d97bda104062ec2467c3644ffcf83d7b98..0a1675573afdc216e77b27fd5333a955c7b5cba1 100644 (file)
@@ -14,6 +14,13 @@ config BR2_PACKAGE_OPENVPN
 
 if BR2_PACKAGE_OPENVPN
 
+config BR2_PACKAGE_OPENVPN_LZ4
+       bool "LZ4 compression"
+       default y
+       select BR2_PACKAGE_LZ4
+       help
+         Enable LZ4 compression.
+
 config BR2_PACKAGE_OPENVPN_LZO
        bool "LZO compression"
        default y
index a2e21f9dd466ab4e8aa0f0eb30a8d1e9249cb7cd..6581a4edd46d1a5bfe368fe2d959da7d85ab390b 100644 (file)
@@ -35,6 +35,12 @@ else
 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
 endif
 
+ifeq ($(BR2_PACKAGE_OPENVPN_LZ4),y)
+OPENVPN_DEPENDENCIES += lz4
+else
+OPENVPN_CONF_OPTS += --disable-lz4
+endif
+
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
 OPENVPN_DEPENDENCIES += lzo
 else