apitrace: new package
authorJérôme Pouiller <jezz@sysmic.org>
Thu, 2 Jan 2014 21:27:40 +0000 (22:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Jan 2014 22:56:10 +0000 (23:56 +0100)
Trace and replay OpenGL and OpenGL ES APIs calls to/from a file.

http://apitrace.github.io/

[Peter: fix Config.in, depend on glibc, use github helper]
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/apitrace/Config.in [new file with mode: 0644]
package/apitrace/apitrace.mk [new file with mode: 0644]

index 38db5de66f89e76b03dba9d3312cf18d79038eaa..a0fb70446900eb8b57d71b8a119ef28aa9287f11 100644 (file)
@@ -215,6 +215,7 @@ source "package/x11r7/Config.in"
 
 comment "X applications"
 source "package/alsamixergui/Config.in"
+source "package/apitrace/Config.in"
 source "package/docker/Config.in"
 source "package/feh/Config.in"
 source "package/freerdp/Config.in"
diff --git a/package/apitrace/Config.in b/package/apitrace/Config.in
new file mode 100644 (file)
index 0000000..6491463
--- /dev/null
@@ -0,0 +1,16 @@
+comment "apitrace needs a (e)glibc toolchain w/ C++"
+       depends on BR2_PACKAGE_XORG7
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_USES_GLIBC
+
+config BR2_PACKAGE_APITRACE
+       bool "apitrace"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_USES_GLIBC # uses glibc specific __libc_dlsym
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBX11
+       help
+         Trace and replay OpenGL and OpenGL ES APIs calls to/from a
+         file. You may install apitrace GUI from your distribution to
+         inspect generated traces.
+
+         http://apitrace.github.io/
diff --git a/package/apitrace/apitrace.mk b/package/apitrace/apitrace.mk
new file mode 100644 (file)
index 0000000..a07ae7d
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# apitrace
+#
+################################################################################
+
+APITRACE_VERSION = c181b7fbf4b1c3912424761fec8ac7124640543a
+APITRACE_SITE = $(call github,apitrace,apitrace,$(APITRACE_VERSION))
+APITRACE_LICENSE = MIT
+APITRACE_LICENSE_FILES = LICENSE
+
+APITRACE_DEPENDENCIES = xlib_libX11 host-python
+
+# Gui was never tested, so we prefer to explicitly disable it
+APITRACE_CONF_OPT += -DENABLE_GUI=false
+
+$(eval $(cmake-package))