package/bdwgc: fix pthread detection on uclinux platforms
authorRomain Naour <romain.naour@gmail.com>
Sat, 6 Aug 2016 21:46:37 +0000 (23:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Aug 2016 21:10:38 +0000 (23:10 +0200)
bdwgc does not recognize "uclinux" as a valid OS part of the target
tuple which is used by some arm cortex-M toolchains.

Fixes:
http://autobuild.buildroot.net/results/94f/94fbc1e5afe183e5b071d1e869b2d780025389e2

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bdwgc/0004-configure-match-uclinux-pattern.patch [new file with mode: 0644]

diff --git a/package/bdwgc/0004-configure-match-uclinux-pattern.patch b/package/bdwgc/0004-configure-match-uclinux-pattern.patch
new file mode 100644 (file)
index 0000000..78bad1c
--- /dev/null
@@ -0,0 +1,32 @@
+From f8ecc7fb09adf34a23d324f373e667c81311fc1c Mon Sep 17 00:00:00 2001
+From: Romain Naour <romain.naour@gmail.com>
+Date: Sat, 6 Aug 2016 23:24:35 +0200
+Subject: [PATCH] configure: match uclinux pattern
+
+bdwgc does not recognize "uclinux" as a valid OS part of the target
+tuple which is used by some arm cortex-M toolchains.
+
+Fixes:
+http://autobuild.buildroot.net/results/94f/94fbc1e5afe183e5b071d1e869b2d780025389e2
+
+Signed-off-by: Romain Naour <romain.naour@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index b1ce2b2..a69d101 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -186,7 +186,7 @@ case "$THREADS" in
+         AC_DEFINE(THREAD_LOCAL_ALLOC)
+         AC_MSG_WARN("Explicit GC_INIT() calls may be required.");
+         ;;
+-     *-*-linux*)
++     *-*-*linux*)
+         AC_DEFINE(GC_LINUX_THREADS)
+         AC_DEFINE(_REENTRANT)
+         ;;
+-- 
+2.5.5
+