package/wf111: do a direct download
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 3 Feb 2018 17:05:59 +0000 (18:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Feb 2018 19:05:59 +0000 (20:05 +0100)
We can now do a download without prior registration, so we can drop the
requirement for a local, pre-downloaded tarball, now.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Julien CORJON <corjon.j@ecagroup.com>
Cc: Antoine Ténart <antoine.tenart@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wf111/Config.in
package/wf111/wf111.mk

index 081bd960cbc14ee92a81ef5030e3414780e14e48..7b61ea195f2f3007a06b090950cce195be9cbfa4 100644 (file)
@@ -19,17 +19,6 @@ config BR2_PACKAGE_WF111
 
          https://www.silabs.com/products/wireless/wi-fi/wf111-bluegiga-module
 
-if BR2_PACKAGE_WF111
-
-config BR2_PACKAGE_WF111_TARBALL_PATH
-       string "Local tarball location"
-       help
-         The WF111 tarball can be retrieved on the Silicon Labs
-         website after registration. This option specifies the path
-         where the tarball is locally saved.
-
-endif
-
 comment "wf111 needs a glibc toolchain"
        depends on BR2_LINUX_KERNEL
        depends on BR2_ARM_CPU_ARMV5 || BR2_ARM_CPU_ARMV7A || BR2_i386
index 5178944fa3085c0254a0f53c44f14f444e974533..72526333fd49cb7d751cd27361a319e114298dc2 100644 (file)
@@ -5,14 +5,9 @@
 ################################################################################
 
 WF111_VERSION = 5-2-2-r3
-WF111_SITE_METHOD = file
-WF111_SITE = $(call qstrip,$(BR2_PACKAGE_WF111_TARBALL_PATH))
+WF111_SITE = https://www.silabs.com/documents/login/software
 WF111_DEPENDENCIES = linux
 
-ifeq ($(BR2_PACKAGE_WF111)$(call qstrip,$(BR2_PACKAGE_WF111_TARBALL_PATH)),y)
-$(error No tarball location specified, check BR2_PACKAGE_WF111_TARBALL_PATH)
-endif
-
 ifeq ($(BR2_ARM_CPU_ARMV7A),y)
 WF111_SOURCE = wf111-linux-driver-$(WF111_VERSION)-armv7-a.tar.gz
 else ifeq ($(BR2_ARM_CPU_ARMV5),y)