package/libv4l: add optional support for libgl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Jun 2016 20:07:21 +0000 (22:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jun 2016 20:26:03 +0000 (22:26 +0200)
libv4l has optional support for OpenGL:
https://git.linuxtv.org/v4l-utils.git/tree/configure.ac#n160

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libv4l/libv4l.mk

index e7a57f08bf7d3c8abd8e987b4207312a77c7a88d..a73b6cf1139b4f9ac4fe87922907632f850f8272 100644 (file)
@@ -36,6 +36,10 @@ else
 LIBV4L_CONF_OPTS += --without-jpeg
 endif
 
+ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
+LIBV4L_DEPENDENCIES += libgl
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
 LIBV4L_CONF_OPTS += --with-libudev
 LIBV4L_DEPENDENCIES += udev