luaposix: New package
authorAssaf Inbal <shmuelzon@gmail.com>
Thu, 20 Jun 2013 04:40:50 +0000 (07:40 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Jun 2013 10:04:39 +0000 (12:04 +0200)
Luaposix is a Lua frontend to posix functions.

Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/luaposix/Config.in [new file with mode: 0644]
package/luaposix/luaposix-remove-lua-header-check.patch [new file with mode: 0644]
package/luaposix/luaposix.mk [new file with mode: 0644]

index 2d8c936934064a713880b2a9b0fde38c8e6598b2..0eb6a9cdb1e3b77eaa98529a1e2265f2ebaf671f 100644 (file)
@@ -321,6 +321,7 @@ source "package/luacrypto/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luaexpatutils/Config.in"
 source "package/luafilesystem/Config.in"
+source "package/luaposix/Config.in"
 source "package/luasocket/Config.in"
 source "package/lua-ev/Config.in"
 source "package/lua-msgpack-native/Config.in"
diff --git a/package/luaposix/Config.in b/package/luaposix/Config.in
new file mode 100644 (file)
index 0000000..412e07f
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LUAPOSIX
+       bool "luaposix"
+       help
+         luaposix is a POSIX binding, including curses, for Lua 5.1
+         and 5.2; Like most libraries it simply binds to C APIs on
+         the underlying system, so it won't work on a non-POSIX
+         system. However, it does try to detect the level of POSIX
+         conformance of the underlying system and bind only available
+         APIs
+
+         https://github.com/luaposix/luaposix
diff --git a/package/luaposix/luaposix-remove-lua-header-check.patch b/package/luaposix/luaposix-remove-lua-header-check.patch
new file mode 100644 (file)
index 0000000..7909b91
--- /dev/null
@@ -0,0 +1,16 @@
+Checking the Lua version inside the headers requires compiling a small
+C program. However, autoconf will raise an error when attempting to do so
+while cross-compiling. Hence, this specific test is removed.
+
+Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
+--- a/configure.ac     2013-06-20 07:23:27.943091833 +0300
++++ b/configure.ac     2013-06-20 07:23:30.644441710 +0300
+@@ -105,7 +105,7 @@
+ dnl Lua 5.1 or 5.2
+ AX_PROG_LUA(501, 503)
+ AX_LUA_HEADERS
+-AX_LUA_HEADERS_VERSION(501, 503)
++#AX_LUA_HEADERS_VERSION(501, 503)
+ AC_SUBST(LUA)
+ AC_SUBST(LUA_INCLUDE)
diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
new file mode 100644 (file)
index 0000000..1d1ee6a
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# luaposix
+#
+################################################################################
+
+LUAPOSIX_VERSION = 5.1.20
+LUAPOSIX_SITE = https://github.com/downloads/luaposix/luaposix
+LUAPOSIX_LICENSE = MIT
+LUAPOSIX_LICENSE_FILES = COPYING
+LUAPOSIX_DEPENDENCIES = lua host-lua
+LUAPOSIX_CONF_OPT = --libdir="/usr/lib/lua" --datarootdir="/usr/share/lua"
+LUAPOSIX_AUTORECONF = YES
+
+$(eval $(autotools-package))