cairo, icu, webkitgtk24: use BR2_TOOLCHAIN_HAS_LIBATOMIC
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Mar 2016 20:47:17 +0000 (21:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Mar 2016 22:40:35 +0000 (23:40 +0100)
This commit modifies the cairo, icu and webkitgtk24 packages to use
BR2_TOOLCHAIN_HAS_LIBATOMIC when appropriate.

Fixes:

  http://autobuild.buildroot.net/results/ec4/ec4e48c0e4b8fa72d8bb7ef4ad67a166699c0b62/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cairo/cairo.mk
package/icu/icu.mk
package/webkitgtk24/webkitgtk24.mk

index 6b54b286e187838b44f2024634e3da68e63614c2..b6ab54eaa02d841d39d8129e4821d272f9ec3ea7 100644 (file)
@@ -18,7 +18,7 @@ endif
 
 # cairo can use C++11 atomics when available, so we need to link with
 # libatomic for the architectures who need libatomic.
-ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_4_8),y)
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 CAIRO_CONF_ENV += LIBS="-latomic"
 endif
 
index 68ea1ff7c4e3fb48160d3e7db40c42dc3aace149..40fe4b83468c180efecd05c4e7a91bc8d12ceb3c 100644 (file)
@@ -21,7 +21,7 @@ ICU_CONF_OPTS = \
 # When available, icu prefers to use C++11 atomics, which rely on the
 # __atomic builtins. On certain architectures, this requires linking
 # with libatomic starting from gcc 4.8.
-ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_4_8),y)
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 ICU_CONF_ENV += LIBS="-latomic"
 endif
 
index 2803d441836e3b4e4a958e8dd6160a0acc5e3923..4b7d6949d47df8992acd89706b904a8fd7f32562 100644 (file)
@@ -29,7 +29,7 @@ endif
 WEBKITGTK24_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config
 
 # Some 32-bit architectures need libatomic support for 64-bit ops
-ifeq ($(BR2_i386)$(BR2_mips)$(BR2_mipsel)$(BR2_sh),y)
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 WEBKITGTK24_CONF_ENV += LIBS="-latomic"
 endif