target-finalize: libtread_db: support nonstd toolchain setups
authorMike Frysinger <vapier@gentoo.org>
Sun, 28 Nov 2010 21:10:13 +0000 (22:10 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Nov 2010 21:13:05 +0000 (22:13 +0100)
Certain toolchain configs (E.G. on blackfin), don't use symlinks, so the
file name to match is the actual SONAME (.so.*). Support these toolchains
as well.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index fc165e1b51b555dea4363e363ca0b970d74eef69..8dbb026b7f1aca9a2e538cb7738ea71a231fd662 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -418,7 +418,7 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
        rm -rf $(TARGET_DIR)/usr/share/gtk-doc
        -rmdir $(TARGET_DIR)/usr/share 2>/dev/null
 endif
-       find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so' | \
+       find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so*' | \
                xargs $(STRIPCMD) 2>/dev/null || true
        find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
                xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)