sdl: fix build of other sdl components
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 16 Jul 2010 09:18:11 +0000 (11:18 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jul 2010 22:09:35 +0000 (00:09 +0200)
The post installation hook of SDL was not being executed, due to an
incorrect usage of the infrastructure. Moreover, it did not patch
prefix/exec_prefix in sdl-config as is needed. In addition to that, we
remove the -Wl,-rpath option from sdl-config, since it is not needed.

This fixes at least the build of sdl_image, and probably of other sdl
components as well.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl/sdl.mk

index 87c753370995a1bb6b3eb2bf7d710e986aa27767..38341374b32f2fbbc89a26abad9d76874f0ea6c7 100644 (file)
@@ -46,11 +46,19 @@ SDL_CONF_OPT += --enable-pulseaudio=no \
                --disable-esd \
                --disable-nasm
 
-define SDL_POST_INSTALL_STAGING_HOOKS
-       $(SED) 's^libdir=\$${exec_prefix}^libdir=/usr^' \
-               $(STAGING_DIR)/usr/bin/sdl-config
+# Fixup prefix= and exec_prefix= in sdl-config, and remove the
+# -Wl,-rpath option.
+define SDL_FIXUP_SDL_CONFIG
+       $(SED) 's%prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
+               $(STAGING_DIR)/usr/bin/sdl-config
+       $(SED) 's%exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
+               $(STAGING_DIR)/usr/bin/sdl-config
+       $(SED) 's%-Wl,-rpath,\$${libdir}%%' \
+               $(STAGING_DIR)/usr/bin/sdl-config
 endef
 
+SDL_POST_INSTALL_STAGING_HOOKS+=SDL_FIXUP_SDL_CONFIG
+
 define SDL_INSTALL_TARGET_CMDS
        cp -dpf $(STAGING_DIR)/usr/lib/libSDL*.so* $(TARGET_DIR)/usr/lib/
 endef