python-aiocoap: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 13 Sep 2017 14:18:59 +0000 (16:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 22 Sep 2017 21:35:37 +0000 (23:35 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-aiocoap/Config.in [new file with mode: 0644]
package/python-aiocoap/python-aiocoap.hash [new file with mode: 0644]
package/python-aiocoap/python-aiocoap.mk [new file with mode: 0644]

index 48d138192156bf3d1084e43b77e8bde161af58bb..5797018a52eed78cacf4b3ead6468d913f785c26 100644 (file)
@@ -691,6 +691,7 @@ endif
        source "package/python3/Config.in"
 if BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
 menu "External python modules"
+       source "package/python-aiocoap/Config.in"
        source "package/python-alsaaudio/Config.in"
        source "package/python-argh/Config.in"
        source "package/python-arrow/Config.in"
diff --git a/package/python-aiocoap/Config.in b/package/python-aiocoap/Config.in
new file mode 100644 (file)
index 0000000..cf5ca4e
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_AIOCOAP
+       bool "python-aiocoap"
+       depends on BR2_PACKAGE_PYTHON3
+       help
+         Python CoAP library.
+
+         https://github.com/chrysn/aiocoap
diff --git a/package/python-aiocoap/python-aiocoap.hash b/package/python-aiocoap/python-aiocoap.hash
new file mode 100644 (file)
index 0000000..6df482a
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/aiocoap/json, sha256 locally computed
+md5    f5fed00767b4197f2fbaa0ff95cbbf78  aiocoap-0.3.tar.gz
+sha256 402d4151db6d8d0b1d66af5b6e10e0de1521decbf12140637e5b8d2aa9c5aef6  aiocoap-0.3.tar.gz
+sha256  2bb211d412a6bfa4b2a9cf01123c7fe90e5e6185938896e23ab07b84f8494180  LICENSE
diff --git a/package/python-aiocoap/python-aiocoap.mk b/package/python-aiocoap/python-aiocoap.mk
new file mode 100644 (file)
index 0000000..a2db70b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-aiocoap
+#
+################################################################################
+
+PYTHON_AIOCOAP_VERSION = 0.3
+PYTHON_AIOCOAP_SOURCE = aiocoap-$(PYTHON_AIOCOAP_VERSION).tar.gz
+PYTHON_AIOCOAP_SITE = https://pypi.python.org/packages/9c/f6/d839e4b14258d76e74a39810829c13f8dd31de2bfe0915579b2a609d1bbe
+PYTHON_AIOCOAP_SETUP_TYPE = setuptools
+PYTHON_AIOCOAP_LICENSE = MIT
+PYTHON_AIOCOAP_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))