Add new package: cpuload
authorKelvin Cheung <keguang.zhang@gmail.com>
Mon, 6 Aug 2012 02:26:26 +0000 (10:26 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 6 Aug 2012 10:49:29 +0000 (12:49 +0200)
cpuload is a simple tool to obtain intuitive vision of CPU load
(including total, user, system, irq and softirq) within a certain
time, which is especially useful for embedded system without GUI.

Signed-off-by: Kelvin Cheung <keguang.zhang@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/cpuload/Config.in [new file with mode: 0644]
package/cpuload/cpuload.mk [new file with mode: 0644]

index f308de79370dfd1320cfbbfccdfe840fdd5f1707..c9ad06a7c0199115c0ebe49517cdba819ff06dd0 100644 (file)
@@ -663,6 +663,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/bootutils/Config.in"
 endif
 source "package/bwm-ng/Config.in"
+source "package/cpuload/Config.in"
 source "package/htop/Config.in"
 source "package/kmod/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
diff --git a/package/cpuload/Config.in b/package/cpuload/Config.in
new file mode 100644 (file)
index 0000000..82bc450
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_CPULOAD
+       bool "cpuload"
+       help
+         cpuload is a simple tool to obtain intuitive vision of CPU load
+         (including total, user, system, irq and softirq) within a certain
+         time, which is especially useful for embedded system without GUI.
+
+         https://github.com/kelvincheung/cpuload
diff --git a/package/cpuload/cpuload.mk b/package/cpuload/cpuload.mk
new file mode 100644 (file)
index 0000000..d25c504
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# cpuload
+#
+#############################################################
+
+CPULOAD_VERSION = v0.3
+CPULOAD_SITE = git://github.com/kelvincheung/cpuload.git
+CPULOAD_LICENSE = GPLv2
+CPULOAD_LICENSE_FILES = COPYING
+
+
+$(eval $(autotools-package))