libevent: disable openssl for host
authorBaruch Siach <baruch@tkos.co.il>
Tue, 28 Nov 2017 15:23:21 +0000 (17:23 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 29 Nov 2017 16:38:15 +0000 (17:38 +0100)
As host-libevent does not depend on host-openssl, it might attempt to
build against the host installed openssl. This does not work very well
on various hosts. Since we don't really need encryption support in
host-libevent just disable openssl support.

Disable build of example code as we already do for the target libevent.

Should fix:
http://autobuild.buildroot.net/results/403/403886e3afc6d5d18a138f4b0651f3c5a50ed064/
http://autobuild.buildroot.net/results/a2a/a2a84692049b0fb8038f1ad4b06554ecdac32e3c/
http://autobuild.buildroot.net/results/a36/a36abb1ac556a8b50e140ea1851955744b152608/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libevent/libevent.mk

index fc4108f6fd081df89a1edfaf25f1f3e40bbdb986..65bf1c2b7b9f91e07e266988f6cb23bcff6ff819 100644 (file)
@@ -12,6 +12,7 @@ LIBEVENT_LICENSE_FILES = LICENSE
 # For 0001-Disable-building-test-programs.patch
 LIBEVENT_AUTORECONF = YES
 LIBEVENT_CONF_OPTS = --disable-samples
+HOST_LIBEVENT_CONF_OPTS = --disable-samples --disable-openssl
 
 define LIBEVENT_REMOVE_PYSCRIPT
        rm $(TARGET_DIR)/usr/bin/event_rpcgen.py