package/libselinux: enable kernel selinux support for f2fs images
authorAdam Duskett <Aduskett@gmail.com>
Fri, 31 Jul 2020 20:40:57 +0000 (13:40 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 13:43:47 +0000 (15:43 +0200)
If BR2_TARGET_ROOTFS_F2FS is selected, enable the following kernel options:
  - CONFIG_F2FS_FS_XATTR
  - CONFIG_F2FS_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libselinux/libselinux.mk

index 44d9ec36577c44727c7a50e0d2dcee59d1466484..c16dcdf1d00eba7e1906d4244a2d895cbbe2a496 100644 (file)
@@ -122,6 +122,9 @@ define LIBSELINUX_LINUX_CONFIG_FIXUPS
                $(call KCONFIG_ENABLE_OPT,CONFIG_EXT3_FS_SECURITY))
        $(if $(BR2_TARGET_ROOTFS_EXT2_4),
                $(call KCONFIG_ENABLE_OPT,CONFIG_EXT4_FS_SECURITY))
+       $(if $(BR2_TARGET_ROOTFS_F2FS),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_XATTR)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_SECURITY))
 endef
 
 $(eval $(generic-package))