sstrip: get rid of host variant
authorJulien Floret <julien.floret@6wind.com>
Thu, 16 Jun 2016 14:41:13 +0000 (16:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Jun 2016 13:36:05 +0000 (15:36 +0200)
Host sstrip is not used anymore.

Signed-off-by: Julien Floret <julien.floret@6wind.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sstrip/sstrip.mk

index fe57b3c19b21110a6278cadc915c2fd383ecfa95..685ea09fbd7743c57c463379eeef033ad9bc7abf 100644 (file)
@@ -6,7 +6,6 @@
 
 SSTRIP_SITE = svn://svn.openwrt.org/openwrt/trunk/tools/sstrip
 SSTRIP_VERSION = 20154
-HOST_SSTRIP_BINARY = $(GNU_TARGET_NAME)-sstrip
 
 define SSTRIP_BUILD_CMDS
        cd $(@D) ; \
@@ -18,15 +17,4 @@ define SSTRIP_INSTALL_TARGET_CMDS
        $(INSTALL) -D $(@D)/sstrip $(TARGET_DIR)/usr/bin/sstrip
 endef
 
-define HOST_SSTRIP_BUILD_CMDS
-       cd $(@D) ; \
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -include byteswap.h \
-               -o sstrip src/sstrip.c
-endef
-
-define HOST_SSTRIP_INSTALL_CMDS
-       $(INSTALL) -D $(@D)/sstrip $(HOST_DIR)/usr/bin/$(HOST_SSTRIP_BINARY)
-endef
-
 $(eval $(generic-package))
-$(eval $(host-generic-package))