package/mtd: install libubi.a and libmtd.a to staging
authorRomain Naour <romain.naour@openwide.fr>
Sun, 7 Sep 2014 09:35:17 +0000 (11:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Sep 2014 19:45:38 +0000 (21:45 +0200)
Currently, the mtd package only installs the mtd utilities into the
target directory. However, the mtd-utils also provide two
static libraries (libmtd.a and libubi.a) that can be used by other
packages or tools.

Therefore, this commit extends the mtd package by adding the
installation to the staging directory of those two libraries.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mtd/mtd.mk

index 80928b61478715ecd47546c60d1147be1c4e7873..1d92f819f791c78de940941064fd4f8bea5d31c7 100644 (file)
@@ -10,6 +10,8 @@ MTD_SITE = ftp://ftp.infradead.org/pub/mtd-utils
 MTD_LICENSE = GPLv2
 MTD_LICENSE_FILES = COPYING
 
+MTD_INSTALL_STAGING = YES
+
 ifeq ($(BR2_PACKAGE_MTD_MKFSJFFS2),y)
 MTD_DEPENDENCIES = zlib lzo
 endif
@@ -36,6 +38,7 @@ endef
 MKFS_JFFS2 = $(HOST_DIR)/usr/sbin/mkfs.jffs2
 SUMTOOL = $(HOST_DIR)/usr/sbin/sumtool
 
+MTD_STAGING_y = lib/libmtd.a ubi-utils/libubi.a
 MTD_TARGETS_$(BR2_PACKAGE_MTD_DOCFDISK)                += docfdisk
 MTD_TARGETS_$(BR2_PACKAGE_MTD_DOC_LOADBIOS)    += doc_loadbios
 MTD_TARGETS_$(BR2_PACKAGE_MTD_FLASHCP)         += flashcp
@@ -79,16 +82,17 @@ MTD_TARGETS_UBI_$(BR2_PACKAGE_MTD_UBIBLOCK) += ubiblock
 MTD_TARGETS_y += $(addprefix ubi-utils/,$(MTD_TARGETS_UBI_y))
 MTD_TARGETS_$(BR2_PACKAGE_MTD_MKFSUBIFS) += mkfs.ubifs/mkfs.ubifs
 
-# only call make if atleast a single tool is enabled
-ifneq ($(MTD_TARGETS_y),)
-
 define MTD_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE1) CROSS=$(TARGET_CROSS) \
                BUILDDIR=$(@D) WITHOUT_XATTR=1 WITHOUT_LARGEFILE=1 -C $(@D) \
-               $(addprefix $(@D)/,$(MTD_TARGETS_y))
+               $(addprefix $(@D)/,$(MTD_TARGETS_y)) \
+               $(addprefix $(@D)/,$(MTD_STAGING_y))
 endef
 
-endif
+define MTD_INSTALL_STAGING_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/lib/libmtd.a $(STAGING_DIR)/usr/lib/libmtd.a
+       $(INSTALL) -D -m 0755 $(@D)/ubi-utils/libubi.a $(STAGING_DIR)/usr/lib/libubi.a
+endef
 
 define MTD_INSTALL_TARGET_CMDS
  for f in $(MTD_TARGETS_y) ; do \