projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9b2bbe3
)
package/gd: Add explicit support for tiff
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Sat, 10 Jan 2015 14:25:24 +0000
(15:25 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 14:28:00 +0000
(15:28 +0100)
This ensures reproducible builds.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gd/gd.mk
patch
|
blob
|
history
diff --git
a/package/gd/gd.mk
b/package/gd/gd.mk
index 868b45e8f34a2d2f8735ab8deec712e0d0c89600..d7a65128fe54f258f5ba40fbf8d1d14524c3ab08 100644
(file)
--- a/
package/gd/gd.mk
+++ b/
package/gd/gd.mk
@@
-52,6
+52,13
@@
else
GD_CONF_OPTS += --without-png
endif
+ifeq ($(BR2_PACKAGE_TIFF),y)
+GD_DEPENDENCIES += tiff
+GD_CONF_OPTS += --with-tiff
+else
+GD_CONF_OPTS += --without-tiff
+endif
+
ifeq ($(BR2_PACKAGE_XLIB_LIBXPM),y)
GD_DEPENDENCIES += xlib_libXpm
GD_CONF_OPTS += --with-xpm