Patch from Michael Shuler. Update to version 1.2.8 and remember to
authorEric Andersen <andersen@codepoet.org>
Sun, 27 Jul 2003 04:00:50 +0000 (04:00 -0000)
committerEric Andersen <andersen@codepoet.org>
Sun, 27 Jul 2003 04:00:50 +0000 (04:00 -0000)
copy all the required shared libs -- without them iptables dosen't
do very much.

make/iptables.mk

index d7f15ae8d98bc1fd7db6c1c7ef7b34d9b4c6cb97..921db7053cde97897de179bab6d2876d5752878e 100644 (file)
@@ -4,8 +4,8 @@
 #
 #############################################################
 IPTABLES_SOURCE_URL=ftp://ftp.netfilter.org/pub/iptables
-IPTABLES_SOURCE=iptables-1.2.7a.tar.bz2
-IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.7a
+IPTABLES_SOURCE=iptables-1.2.8.tar.bz2
+IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.8
 
 $(DL_DIR)/$(IPTABLES_SOURCE):
         $(WGET) -P $(DL_DIR) $(IPTABLES_SOURCE_URL)/$(IPTABLES_SOURCE) 
@@ -28,6 +28,8 @@ $(TARGET_DIR)/sbin/iptables: $(IPTABLES_BUILD_DIR)/iptables
        cp -af $(IPTABLES_BUILD_DIR)/iptables $(TARGET_DIR)/sbin/
        cp -af $(IPTABLES_BUILD_DIR)/iptables-save $(TARGET_DIR)/sbin/
        cp -af $(IPTABLES_BUILD_DIR)/iptables-restore $(TARGET_DIR)/sbin/
+       -mkdir $(TARGET_DIR)/usr/local/lib/iptables
+       cp -af $(IPTABLES_BUILD_DIR)/extensions/*.so $(TARGET_DIR)/usr/local/lib/iptables/
 
 iptables: $(TARGET_DIR)/sbin/iptables