tiff: fix prefer-static build by using default install
authorDanomi Manchego <danomimanchego123@gmail.com>
Fri, 26 Sep 2014 02:09:20 +0000 (22:09 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Sep 2014 20:39:30 +0000 (22:39 +0200)
Replace hand-coded .so install with default install, plus tiff bins fixup
to remove unwanted tools.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tiff/tiff.mk

index 8d2e087b419e3fa3518800d8cac39860088be102..99a5b157dcae5e44dea1ea02f7ba9bbbd54d061c 100644 (file)
@@ -15,12 +15,34 @@ TIFF_CONF_OPT = \
 
 TIFF_DEPENDENCIES = host-pkgconf
 
-TIFF_TOOLS_LIST =
-ifeq ($(BR2_PACKAGE_TIFF_TIFF2PDF),y)
-       TIFF_TOOLS_LIST += tiff2pdf
+TIFF_TOOLS_TO_DELETE = \
+       bmp2tiff \
+       fax2ps \
+       fax2tiff \
+       gif2tiff \
+       pal2rgb \
+       ppm2tiff \
+       ras2tiff \
+       raw2tiff \
+       rgb2ycbcr \
+       thumbnail \
+       tiff2bw \
+       tiff2ps \
+       tiff2rgba \
+       tiffcmp \
+       tiffcrop \
+       tiffdither \
+       tiffdump \
+       tiffinfo \
+       tiffmedian \
+       tiffset \
+       tiffsplit \
+
+ifeq ($(BR2_PACKAGE_TIFF_TIFF2PDF),)
+       TIFF_TOOLS_TO_DELETE += tiff2pdf
 endif
-ifeq ($(BR2_PACKAGE_TIFF_TIFFCP),y)
-       TIFF_TOOLS_LIST += tiffcp
+ifeq ($(BR2_PACKAGE_TIFF_TIFFCP),)
+       TIFF_TOOLS_TO_DELETE += tiffcp
 endif
 
 ifneq ($(BR2_PACKAGE_TIFF_CCITT),y)
@@ -75,12 +97,10 @@ ifneq ($(BR2_PACKAGE_TIFF_JBIG),y)
        TIFF_CONF_OPT += --disable-jbig
 endif
 
-define TIFF_INSTALL_TARGET_CMDS
-       -cp -a $(@D)/libtiff/.libs/libtiff.so* $(TARGET_DIR)/usr/lib/
-       for i in $(TIFF_TOOLS_LIST); \
-       do \
-               $(INSTALL) -m 755 -D $(@D)/tools/$$i $(TARGET_DIR)/usr/bin/$$i; \
-       done
+define TIFF_REMOVE_TOOLS_FIXUP
+       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,$(TIFF_TOOLS_TO_DELETE))
 endef
 
+TIFF_POST_INSTALL_TARGET_HOOKS += TIFF_REMOVE_TOOLS_FIXUP
+
 $(eval $(autotools-package))