-From 7f47f7f8c1a0d634e9febad61504f095476fccc0 Mon Sep 17 00:00:00 2001
+From 99bc38ac6ebdd3b5d741cb9e50d842fa13d409f7 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Tue, 12 May 2015 22:54:29 +0200
Subject: [PATCH] tools: use pkg-config when available to get SSL flags
-lcrypto if pkg-config is not available or fails with an error.
Patch submitted upstream at
-http://lists.denx.de/pipermail/u-boot/2015-May/214068.html.
+http://lists.denx.de/pipermail/u-boot/2015-May/214489.html
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/tools/Makefile b/tools/Makefile
-index 4bbb153..e1bcd59 100644
+index 4bbb153..8ff9c2e 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -122,7 +122,8 @@ endif
ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
-HOSTLOADLIBES_mkimage += -lssl -lcrypto
+HOSTLOADLIBES_mkimage += \
-+ $(shell pkg-config --libs libssl 2> /dev/null || echo "-lssl -lcrypto")
++ $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
endif
HOSTLOADLIBES_dumpimage := $(HOSTLOADLIBES_mkimage)