libcgroup: fix passing CFLAGS/LDFLAGS to configure
authorMax Filippov <jcmvbkbc@gmail.com>
Mon, 12 May 2014 03:27:04 +0000 (07:27 +0400)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 12 May 2014 20:49:07 +0000 (22:49 +0200)
LIBCGROUP_CONF_ENV is a string used to pass environment variables to the
confgiure script, '+=' operator doesn't have any special meaning inside
it, so CFLAGS+=... is passed to shell, overwriting previous CFLAGS
value. Replace CFLAGS+="..." with CFLAGS="$(TARGET_CFLAGS) ...".

Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libcgroup/libcgroup.mk

index 6d7ae54665aa5de6bcf41b311af0846d5fc37d3e..0ef1e912836d126da74a53255288d28ce0cbddb5 100644 (file)
@@ -16,8 +16,8 @@ LIBCGROUP_INSTALL_STAGING = YES
 # large file support. See https://bugzilla.redhat.com/show_bug.cgi?id=574992
 # for more information.
 LIBCGROUP_CONF_ENV = \
-       CXXFLAGS+="-U_FILE_OFFSET_BITS" \
-       CFLAGS+="-U_FILE_OFFSET_BITS"
+       CXXFLAGS="$(TARGET_CXXFLAGS) -U_FILE_OFFSET_BITS" \
+       CFLAGS="$(TARGET_CFLAGS) -U_FILE_OFFSET_BITS"
 
 LIBCGROUP_CONF_OPT = \
        --disable-tools \