libeina: Add new package along with EFL infrastructure
authorWill Newton <will.newton@gmail.com>
Thu, 26 Jan 2012 17:42:25 +0000 (17:42 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 26 Jan 2012 22:02:46 +0000 (23:02 +0100)
[Peter: drop autoreconf, add URL]
Signed-off-by: Will Newton <will.newton@imgtec.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/efl/Config.in [new file with mode: 0644]
package/efl/efl.mk [new file with mode: 0644]
package/efl/libeina/Config.in [new file with mode: 0644]
package/efl/libeina/libeina.mk [new file with mode: 0644]

index 251da8549448360e51928b30de026e5094a93dd4..65c2a98c65e620ad9d227c3fdfb7c55dbfe033f3 100644 (file)
@@ -118,6 +118,7 @@ source "package/sdl_ttf/Config.in"
 source "package/sdl_gfx/Config.in"
 
 comment "other GUIs"
+source "package/efl/Config.in"
 source "package/qt/Config.in"
 source "package/x11r7/Config.in"
 
diff --git a/package/efl/Config.in b/package/efl/Config.in
new file mode 100644 (file)
index 0000000..cc677cb
--- /dev/null
@@ -0,0 +1,16 @@
+menuconfig BR2_PACKAGE_EFL
+       bool "Enlightenment Foundation Libraries"
+       depends on BR2_USE_WCHAR
+       help
+         Enlightenment Foundation Libraries
+
+         http://enlightenment.org
+
+if BR2_PACKAGE_EFL
+
+source "package/efl/libeina/Config.in"
+
+endif # BR2_PACKAGE_EFL
+
+comment "EFL requires WCHAR support in toolchain"
+       depends on !BR2_USE_WCHAR
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
new file mode 100644 (file)
index 0000000..d8d53cf
--- /dev/null
@@ -0,0 +1 @@
+include package/efl/*/*.mk
diff --git a/package/efl/libeina/Config.in b/package/efl/libeina/Config.in
new file mode 100644 (file)
index 0000000..80600ad
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBEINA
+       bool "libeina"
+       help
+         Eina is a tiny library to handle data types (list, hash, etc.)
+
+         http://trac.enlightenment.org/e/wiki/Eina
diff --git a/package/efl/libeina/libeina.mk b/package/efl/libeina/libeina.mk
new file mode 100644 (file)
index 0000000..b457e3f
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libeina
+#
+#############################################################
+
+LIBEINA_VERSION = 1.1.0
+LIBEINA_SOURCE = eina-$(LIBEINA_VERSION).tar.bz2
+LIBEINA_SITE = http://download.enlightenment.org/releases/
+LIBEINA_INSTALL_STAGING = YES
+
+LIBEINA_DEPENDENCIES = host-pkg-config
+
+$(eval $(call AUTOTARGETS))
+$(eval $(call AUTOTARGETS,host))