package/cryptodev: properly declare providers
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 3 Sep 2016 22:58:40 +0000 (00:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Sep 2016 13:38:59 +0000 (15:38 +0200)
cryptodev-linux and ocf-linux are providers of the cryptodev virtual
package, so they must declare themselves as such.

We do not have any problem for now, as the only consumer (openssl) of
both cryptodev-linux and ocf-linux did not depend on the virtual package
but on each provider. The other consumer is gnutls, but has only a
dependency on cryptodev-linux.

However, openssl can be turned into a proper consumer of the virtual
package, which would trigger the bug.

For the sake of correctness, make both cryptodev-linux and ocf-linux
declare themselves as providers for the cryptodev virtual package.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cryptodev-linux/cryptodev-linux.mk
package/ocf-linux/ocf-linux.mk

index c3f53553450007ff0293c995eaa5783959641e56..d23b6474f8716ef33c91a428d250dda9e4e2f7e0 100644 (file)
@@ -10,6 +10,8 @@ CRYPTODEV_LINUX_INSTALL_STAGING = YES
 CRYPTODEV_LINUX_LICENSE = GPLv2+
 CRYPTODEV_LINUX_LICENSE_FILES = COPYING
 
+CRYPTODEV_LINUX_PROVIDES = cryptodev
+
 define CRYPTODEV_LINUX_MODULE_GEN_VERSION_H
        $(MAKE) -C $(@D) version.h
 endef
index 35968d5edc64157ec307799b40f0f582adbbdd20..01854fa73aed001c7b8ede054467b06121dae71d 100644 (file)
@@ -8,6 +8,8 @@ OCF_LINUX_VERSION = 20120127
 OCF_LINUX_SITE = http://downloads.sourceforge.net/project/ocf-linux/ocf-linux/$(OCF_LINUX_VERSION)
 OCF_LINUX_INSTALL_STAGING = YES
 
+OCF_LINUX_PROVIDES = cryptodev
+
 OCF_LINUX_MODULE_SUBDIRS = ocf
 OCF_LINUX_MODULE_MAKE_OPTS = \
        CONFIG_OCF_OCF=m \