neon: cleanup
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 11 Oct 2011 07:23:25 +0000 (09:23 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 11 Oct 2011 07:27:25 +0000 (09:27 +0200)
Whitespace fixes / removal of redundant lines. No functional change.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/neon/neon.mk

index 95664d7dc4c5955eac8af0e9a6eb24a50216c05b..272d5e08442f7a38564d4e403f1da7b218de11df 100644 (file)
@@ -3,46 +3,45 @@
 # neon
 #
 #############################################################
-NEON_VERSION:=0.29.6
-NEON_SITE:=http://www.webdav.org/neon/
-NEON_INSTALL_STAGING:=YES
-NEON_CONF_OPT:=--without-gssapi --disable-rpath
+NEON_VERSION0.29.6
+NEON_SITE = http://www.webdav.org/neon/
+NEON_INSTALL_STAGING = YES
+NEON_CONF_OPT = --without-gssapi --disable-rpath
 
-NEON_DEPENDENCIES:=host-pkg-config
+NEON_DEPENDENCIES = host-pkg-config
 
-ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
-NEON_CONF_OPT+=--with-libxml2=yes
-NEON_CONF_OPT+=--with-expat=no
-NEON_CONF_ENV+=ac_cv_prog_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
-NEON_DEPENDENCIES+=libxml2
-endif
 ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)
-NEON_CONF_OPT+=--with-zlib=$(STAGING_DIR)
-NEON_DEPENDENCIES+=zlib
+NEON_CONF_OPT += --with-zlib=$(STAGING_DIR)
+NEON_DEPENDENCIES += zlib
 else
-NEON_CONF_OPT+=--without-zlib
+NEON_CONF_OPT += --without-zlib
 endif
+
 ifeq ($(BR2_PACKAGE_NEON_SSL),y)
-NEON_CONF_OPT+=--with-ssl
-NEON_DEPENDENCIES+=openssl
+NEON_CONF_OPT += --with-ssl
+NEON_DEPENDENCIES += openssl
 else
-NEON_CONF_OPT+=--without-ssl
+NEON_CONF_OPT += --without-ssl
 endif
+
 ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
-NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
-NEON_CONF_OPT+=--with-libxml2=no
-NEON_DEPENDENCIES+=expat
-endif
-ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
-# webdav needs xml support
-NEON_CONF_OPT+=--disable-webdav
+NEON_CONF_OPT += --with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
+NEON_DEPENDENCIES += expat
+else
+NEON_CONF_OPT += --with-expat=no
 endif
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-NEON_CONF_OPT+=--with-ssl
-NEON_DEPENDENCIES+=openssl
+ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
+NEON_CONF_OPT += --with-libxml2=yes
+NEON_CONF_ENV += ac_cv_prog_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
+NEON_DEPENDENCIES += libxml2
 else
-NEON_CONF_OPT+=--without-ssl
+NEON_CONF_OPT += --with-libxml2=no
+endif
+
+ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
+# webdav needs xml support
+NEON_CONF_OPT += --disable-webdav
 endif
 
 define NEON_REMOVE_CONFIG_SCRIPTS