package/asterisk: add support for SS7
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:31 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index 55370c43b80ade088ba82995cd0b26e6f9d5d1bc..20ae502da27cd599ef2427f45139da98ceefa323 100644 (file)
@@ -87,7 +87,6 @@ ASTERISK_CONF_OPTS = \
        --without-sdl \
        --without-SDL_image \
        --without-spandsp \
-       --without-ss7 \
        --without-sqlite \
        --without-suppserv \
        --without-tds \
@@ -197,8 +196,16 @@ endif
 ifeq ($(BR2_PACKAGE_DAHDI_LINUX)$(BR2_PACKAGE_DAHDI_TOOLS),yy)
 ASTERISK_DEPENDENCIES += dahdi-linux dahdi-tools
 ASTERISK_CONF_OPTS += --with-dahdi --with-tonezone
+
+ifeq ($(BR2_PACKAGE_LIBSS7),y)
+ASTERISK_DEPENDENCIES += libss7
+ASTERISK_CONF_OPTS += --with-ss7
+else
+ASTERISK_CONF_OPTS += --without-ss7
+endif # SS7
+
 else
-ASTERISK_CONF_OPTS += --without-dahdi --without-tonezone
+ASTERISK_CONF_OPTS += --without-dahdi --without-tonezone --without-ss7
 endif # DAHDI
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)