bind: bump version (security issue with DNSSEC DLV)
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Apr 2009 18:29:50 +0000 (18:29 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Apr 2009 18:29:50 +0000 (18:29 -0000)
Patch by Gustavo Zacarias <gustavo@zacarias.com.ar>, closes #275.

package/bind/bind-9.5.1-P1-cross.patch [deleted file]
package/bind/bind-9.5.1-P1-susv3-legacy.patch [deleted file]
package/bind/bind-cross.patch [new file with mode: 0644]
package/bind/bind-susv3-legacy.patch [new file with mode: 0644]
package/bind/bind.mk

diff --git a/package/bind/bind-9.5.1-P1-cross.patch b/package/bind/bind-9.5.1-P1-cross.patch
deleted file mode 100644 (file)
index cdbf4cb..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Nura bind-9.5.1-P1/lib/dns/Makefile.in bind-9.5.1-P1.gencross/lib/dns/Makefile.in
---- bind-9.5.1-P1/lib/dns/Makefile.in  2007-09-11 22:09:08.000000000 -0300
-+++ bind-9.5.1-P1.gencross/lib/dns/Makefile.in 2009-03-04 16:35:23.000000000 -0200
-@@ -160,8 +160,8 @@
-       ./gen -s ${srcdir} > code.h
- gen: gen.c
--      ${BUILD_CC} ${BUILD_CFLAGS} -I${top_srcdir}/lib/isc/include \
--      ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} -o $@ ${srcdir}/gen.c ${BUILD_LIBS}
-+      ${HOSTCC} ${HOST_CFLAGS} -I${top_srcdir}/lib/isc/include \
-+      ${HOST_LDFLAGS} -o $@ ${srcdir}/gen.c
- rbtdb64.@O@: rbtdb.c
diff --git a/package/bind/bind-9.5.1-P1-susv3-legacy.patch b/package/bind/bind-9.5.1-P1-susv3-legacy.patch
deleted file mode 100644 (file)
index 01a38b2..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Nura bind-9.5.1-P1/lib/isc/unix/ifiter_ioctl.c bind-9.5.1-P1.nosusv3/lib/isc/unix/ifiter_ioctl.c
---- bind-9.5.1-P1/lib/isc/unix/ifiter_ioctl.c  2007-08-30 03:02:28.000000000 -0300
-+++ bind-9.5.1-P1.nosusv3/lib/isc/unix/ifiter_ioctl.c  2009-03-04 16:31:20.000000000 -0200
-@@ -17,6 +17,8 @@
- /* $Id: ifiter_ioctl.c,v 1.58 2007/08/30 06:02:28 marka Exp $ */
-+#include <string.h>
-+
- /*! \file
-  * \brief
-  * Obtain the list of network interfaces using the SIOCGLIFCONF ioctl.
-@@ -479,8 +481,8 @@
-       for (i = 0; i < 16; i++) {
-               unsigned char byte;
-               static const char hex[] = "0123456789abcdef";
--              byte = ((index(hex, address[i * 2]) - hex) << 4) |
--                     (index(hex, address[i * 2 + 1]) - hex);
-+              byte = ((strchr(hex, address[i * 2]) - hex) << 4) |
-+                      (strchr(hex, address[i * 2 + 1]) - hex);
-               addr6.s6_addr[i] = byte;
-       }
-       iter->current.af = AF_INET6;
diff --git a/package/bind/bind-cross.patch b/package/bind/bind-cross.patch
new file mode 100644 (file)
index 0000000..cdbf4cb
--- /dev/null
@@ -0,0 +1,14 @@
+diff -Nura bind-9.5.1-P1/lib/dns/Makefile.in bind-9.5.1-P1.gencross/lib/dns/Makefile.in
+--- bind-9.5.1-P1/lib/dns/Makefile.in  2007-09-11 22:09:08.000000000 -0300
++++ bind-9.5.1-P1.gencross/lib/dns/Makefile.in 2009-03-04 16:35:23.000000000 -0200
+@@ -160,8 +160,8 @@
+       ./gen -s ${srcdir} > code.h
+ gen: gen.c
+-      ${BUILD_CC} ${BUILD_CFLAGS} -I${top_srcdir}/lib/isc/include \
+-      ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} -o $@ ${srcdir}/gen.c ${BUILD_LIBS}
++      ${HOSTCC} ${HOST_CFLAGS} -I${top_srcdir}/lib/isc/include \
++      ${HOST_LDFLAGS} -o $@ ${srcdir}/gen.c
+ rbtdb64.@O@: rbtdb.c
diff --git a/package/bind/bind-susv3-legacy.patch b/package/bind/bind-susv3-legacy.patch
new file mode 100644 (file)
index 0000000..01a38b2
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Nura bind-9.5.1-P1/lib/isc/unix/ifiter_ioctl.c bind-9.5.1-P1.nosusv3/lib/isc/unix/ifiter_ioctl.c
+--- bind-9.5.1-P1/lib/isc/unix/ifiter_ioctl.c  2007-08-30 03:02:28.000000000 -0300
++++ bind-9.5.1-P1.nosusv3/lib/isc/unix/ifiter_ioctl.c  2009-03-04 16:31:20.000000000 -0200
+@@ -17,6 +17,8 @@
+ /* $Id: ifiter_ioctl.c,v 1.58 2007/08/30 06:02:28 marka Exp $ */
++#include <string.h>
++
+ /*! \file
+  * \brief
+  * Obtain the list of network interfaces using the SIOCGLIFCONF ioctl.
+@@ -479,8 +481,8 @@
+       for (i = 0; i < 16; i++) {
+               unsigned char byte;
+               static const char hex[] = "0123456789abcdef";
+-              byte = ((index(hex, address[i * 2]) - hex) << 4) |
+-                     (index(hex, address[i * 2 + 1]) - hex);
++              byte = ((strchr(hex, address[i * 2]) - hex) << 4) |
++                      (strchr(hex, address[i * 2 + 1]) - hex);
+               addr6.s6_addr[i] = byte;
+       }
+       iter->current.af = AF_INET6;
index c0f570bd6f12e6f8cd40bc2f06c6b9d39a684d4c..1bf16279270b453a30765403b0815191edb4d703 100644 (file)
@@ -3,7 +3,7 @@
 # bind
 #
 #############################################################
-BIND_VERSION = 9.5.1-P1
+BIND_VERSION = 9.5.1-P2
 BIND_SOURCE = bind-$(BIND_VERSION).tar.gz
 BIND_SITE = ftp://ftp.isc.org/isc/bind9/$(BIND_VERSION)
 BIND_LIBTOOL_PATCH = NO