collectd: add mqtt plugin support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 22 Dec 2016 01:59:15 +0000 (22:59 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 21:37:38 +0000 (22:37 +0100)
Add explicit support for the mqtt (mosquitto) plugin.
Place it under the write category even though it can read as well, since
it will normally be used to write (publish) rather than read
(subscribe).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/Config.in
package/collectd/collectd.mk

index d1b85aadbe318a107691f93a39ec4475032bd1f2..b17abe830c2909d2a8bf0ea735d79136de752636 100644 (file)
@@ -512,6 +512,12 @@ config BR2_PACKAGE_COLLECTD_GRAPHITE
          Writes data collected to Carbon (Graphite's) storage API.
          http://graphite.wikidot.com/start
 
+config BR2_PACKAGE_COLLECTD_MQTT
+       bool "mqtt"
+       select BR2_PACKAGE_MOSQUITTO
+       help
+         Sends metrics to and/or receives metrics from an MQTT broker.
+
 config BR2_PACKAGE_COLLECTD_NETWORK
        bool "network"
        help
index d8b2576c900f112dc393090ec1c40030732986fa..97e2e98db8c49cbadc192da8526dfe2f25a29789 100644 (file)
@@ -72,6 +72,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_MEMCACHED),--enable-memcached,--disable-memcached) \
        $(if $(BR2_PACKAGE_COLLECTD_MEMORY),--enable-memory,--disable-memory) \
        $(if $(BR2_PACKAGE_COLLECTD_MODBUS),--enable-modbus,--disable-modbus) \
+       $(if $(BR2_PACKAGE_COLLECTD_MQTT),--enable-mqtt,--disable-mqtt) \
        $(if $(BR2_PACKAGE_COLLECTD_MYSQL),--enable-mysql,--disable-mysql) \
        $(if $(BR2_PACKAGE_COLLECTD_NETLINK),--enable-netlink,--disable-netlink) \
        $(if $(BR2_PACKAGE_COLLECTD_NETWORK),--enable-network,--disable-network) \
@@ -133,6 +134,7 @@ COLLECTD_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_COLLECTD_LOGSTASH),yajl) \
        $(if $(BR2_PACKAGE_COLLECTD_MEMCACHEC),libmemcached) \
        $(if $(BR2_PACKAGE_COLLECTD_MODBUS),libmodbus) \
+       $(if $(BR2_PACKAGE_COLLECTD_MQTT),mosquitto) \
        $(if $(BR2_PACKAGE_COLLECTD_MYSQL),mysql) \
        $(if $(BR2_PACKAGE_COLLECTD_NETLINK),libmnl) \
        $(if $(BR2_PACKAGE_COLLECTD_NGINX),libcurl) \