Globally disable PKG_CONFIG_PATH
authorArnout Vandecappelle <arnout@mind.be>
Sat, 30 Jun 2012 10:29:22 +0000 (10:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 30 Jun 2012 22:27:39 +0000 (00:27 +0200)
If PKG_CONFIG_PATH is set in the environment, it allows pkg-config to
look for libraries outside of the buildroot tree.  This is a problem
both for host and target builds.  To avoid it, globally set an empty
PKG_CONFIG_PATH in the environment.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 7a66897cc27d0694ce9c408e5a21ae3b63499f3f..bcbe9fc10c2adbdf1003486345d9a63fb2902df6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -165,6 +165,9 @@ HOSTNM:=$(shell which $(HOSTNM) || type -p $(HOSTNM) || echo nm)
 export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD
 export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
 
+# Make sure pkg-config doesn't look outside the buildroot tree
+unexport PKG_CONFIG_PATH
+
 # bash prints the name of the directory on 'cd <dir>' if CDPATH is
 # set, so unset it here to not cause problems. Notice that the export
 # line doesn't affect the environment of $(shell ..) calls, so