util-linux: disable useless programs in the host package
authorCarlos Santos <casantos@datacom.ind.br>
Fri, 26 Jan 2018 00:16:52 +0000 (22:16 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Jan 2018 08:07:08 +0000 (09:07 +0100)
Disable all programs that depend on ncurses, as well as utilities that
are useless on the host: agetty, chfn-chsh, chmem, login, lslogins,
mesg, more, newgrp, nologin, nsenter, pg, rfkill, schedutils, setpriv,
setterm, su, sulogin, tunelp, ul, unshare, uuidd, vipw, wall, wdctl,
write, zramctl.

Also add dependency on host-zlib if host cramfs utils are to be built.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/util-linux/util-linux.mk

index e368464e8d7c31333f55617698650cccbbc93560..72a6d181786c497cfe963a8afe3a4a9590b95c8e 100644 (file)
@@ -172,8 +172,37 @@ HOST_UTIL_LINUX_CONF_OPTS += \
 
 ifeq ($(BR2_PACKAGE_HOST_UTIL_LINUX),y)
 HOST_UTIL_LINUX_CONF_OPTS += --disable-makeinstall-chown
-# disable more command because of ncurses dependency
-HOST_UTIL_LINUX_CONF_OPTS += --disable-more
+# disable commands that have ncurses dependency, as well as
+# other ones that are useless on the host
+HOST_UTIL_LINUX_CONF_OPTS += \
+       --disable-agetty \
+       --disable-chfn-chsh \
+       --disable-chmem \
+       --disable-login \
+       --disable-lslogins \
+       --disable-mesg \
+       --disable-more \
+       --disable-newgrp \
+       --disable-nologin \
+       --disable-nsenter \
+       --disable-pg \
+       --disable-rfkill \
+       --disable-schedutils \
+       --disable-setpriv \
+       --disable-setterm \
+       --disable-su \
+       --disable-sulogin \
+       --disable-tunelp \
+       --disable-ul \
+       --disable-unshare \
+       --disable-uuidd \
+       --disable-vipw \
+       --disable-wall \
+       --disable-wdctl \
+       --disable-write \
+       --disable-zramctl
+# Used by cramfs utils
+HOST_UTIL_LINUX_DEPENDENCIES += host-zlib
 else
 HOST_UTIL_LINUX_CONF_OPTS += --disable-all-programs
 endif