binutils: arc: Use git instead of website
authorMischa Jonker <mischa.jonker@synopsys.com>
Thu, 5 Dec 2013 17:20:48 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 21:40:12 +0000 (22:40 +0100)
Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/binutils/Config.in.host
package/binutils/binutils.mk

index 63830fbfa6f673a8747d07e534919d11507343b7..ef833eca2a5360d072dc45c855213414badf1c7e 100644 (file)
@@ -48,7 +48,7 @@ endchoice
 config BR2_BINUTILS_VERSION
        string
        default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
-       default "2.23.2-arc"    if BR2_arc
+       default "0c824ba511fa9b028220eb3c39b566af89ac9dda" if BR2_arc
        default "2.20.1"        if BR2_BINUTILS_VERSION_2_20_1
        default "2.21"          if BR2_BINUTILS_VERSION_2_21
        default "2.21.1"        if BR2_BINUTILS_VERSION_2_21_1
index b3ccee2bcbec590effdac22d1865df97c038d695..3c148492791d8d363a2a94964de5ec5f2e4ea0b1 100644 (file)
@@ -18,17 +18,17 @@ endif
 
 ifeq ($(BINUTILS_VERSION),2.23)
 BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
-else
-BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.bz2
 endif
 
-BINUTILS_SITE = $(BR2_GNU_MIRROR)/binutils
 ifeq ($(ARCH),avr32)
 BINUTILS_SITE = ftp://www.at91.com/pub/buildroot
 endif
 ifeq ($(BR2_arc),y)
-BINUTILS_SITE = $(BR2_ARC_SITE)
+BINUTILS_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,binutils,$(BINUTILS_VERSION))
+BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
 endif
+BINUTILS_SITE ?= $(BR2_GNU_MIRROR)/binutils
+BINUTILS_SOURCE ?= binutils-$(BINUTILS_VERSION).tar.bz2
 BINUTILS_EXTRA_CONFIG_OPTIONS = $(call qstrip,$(BR2_BINUTILS_EXTRA_CONFIG_OPTIONS))
 BINUTILS_INSTALL_STAGING = YES
 BINUTILS_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)