jhead: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 27 Mar 2013 07:03:59 +0000 (07:03 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Mar 2013 19:31:41 +0000 (20:31 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/jhead/Config.in [new file with mode: 0644]
package/jhead/jhead-use-ldflags.patch [new file with mode: 0644]
package/jhead/jhead.mk [new file with mode: 0644]

index 77dc0d3a1913bfdfe3cc49c35e0f89aef0339c16..d522804b56aa222c43c9ea383eb4088e97326640 100644 (file)
@@ -107,6 +107,7 @@ menu "Graphic libraries and applications (graphic/text)"
 
 comment "Graphic applications"
 source "package/gnuplot/Config.in"
+source "package/jhead/Config.in"
 source "package/rrdtool/Config.in"
 
 comment "graphic libraries"
diff --git a/package/jhead/Config.in b/package/jhead/Config.in
new file mode 100644 (file)
index 0000000..247ac53
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_JHEAD
+       bool "jhead"
+       depends on BR2_USE_WCHAR
+       help
+         Jhead is a program for manipulating settings and thumbnails
+         in Exif jpeg headers used by most Digital Cameras.
+
+         http://www.sentex.net/~mwandel/jhead/
+
+comment "jhead requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
diff --git a/package/jhead/jhead-use-ldflags.patch b/package/jhead/jhead-use-ldflags.patch
new file mode 100644 (file)
index 0000000..a1d8185
--- /dev/null
@@ -0,0 +1,16 @@
+Make jhead use LDFLAGS for the final link.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura jhead-2.97.orig/makefile jhead-2.97/makefile
+--- jhead-2.97.orig/makefile   2013-03-27 09:22:38.759966389 -0300
++++ jhead-2.97/makefile        2013-03-27 09:25:06.290691745 -0300
+@@ -14,7 +14,7 @@
+       ${CC} $(CFLAGS) -c $< -o $@
+ jhead: $(objs) jhead.h
+-      ${CC} -o jhead $(objs) -lm
++      ${CC} $(LDFLAGS) -o jhead $(objs) -lm
+ clean:
+       rm -f $(objs) jhead
diff --git a/package/jhead/jhead.mk b/package/jhead/jhead.mk
new file mode 100644 (file)
index 0000000..e9843ae
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# jhead
+#
+#############################################################
+
+JHEAD_VERSION = 2.97
+JHEAD_SITE = http://www.sentex.net/~mwandel/jhead
+JHEAD_LICENSE = Public Domain
+JHEAD_LICENSE_FILES = readme.txt
+
+define JHEAD_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define JHEAD_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/jhead $(TARGET_DIR)/usr/bin/jhead
+endef
+
+$(eval $(generic-package))