kmod: really pass --disable-manpages
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Feb 2014 08:34:17 +0000 (09:34 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Feb 2014 08:35:54 +0000 (09:35 +0100)
The line below overwrites KMOD_CONF_OPT, so move the --disable-manpages
options below.

Fixes http://autobuild.buildroot.net/results/842/842131307c171e1bc5a1e918996d53b00ddb1be3/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kmod/kmod.mk

index f819d0eb8e7a01bbd34eb63c35b359c095bab495..f79a492847cee30cdf807ff0877746131994dbdf 100644 (file)
@@ -15,13 +15,13 @@ HOST_KMOD_DEPENDENCIES = host-pkgconf
 KMOD_LICENSE = LGPLv2.1+
 KMOD_LICENSE_FILES = libkmod/COPYING
 
-KMOD_CONF_OPT += --disable-manpages
-HOST_KMOD_CONF_OPT = --disable-manpages
-
 # static linking not supported, see
 # https://git.kernel.org/cgit/utils/kernel/kmod/kmod.git/commit/?id=b7016153ec8
 KMOD_CONF_OPT = --disable-static --enable-shared
 
+KMOD_CONF_OPT += --disable-manpages
+HOST_KMOD_CONF_OPT = --disable-manpages
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 KMOD_DEPENDENCIES += zlib
 KMOD_CONF_OPT += --with-zlib