package/qt5: change upstream location
authorYann E. MORIN <yann.morin@orange.com>
Tue, 30 Jul 2019 10:36:00 +0000 (12:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Jul 2019 15:55:02 +0000 (17:55 +0200)
Upstream pushes their delivery archives in to places:
    https://download.qt.io/official_releases/
    https://download.qt.io/archive/

After a while, only the latter remains, whith the former being pruned
actively to contain only officially supported versions.

Switch to using the archive location, as it has everything, even the
latest versions.

Signed-off-by: "Yann E. MORIN" <yann.morin@orange.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5.mk

index 247748ca4de48b099887b5ce1320352ae87cd281..468c1ac4d590e9110eba222d02ca7229ec465838 100644 (file)
@@ -13,7 +13,7 @@ QT5_VERSION_MAJOR = 5.6
 QT5_VERSION = $(QT5_VERSION_MAJOR).3
 QT5_SOURCE_TARBALL_PREFIX = opensource-src
 endif
-QT5_SITE = https://download.qt.io/official_releases/qt/$(QT5_VERSION_MAJOR)/$(QT5_VERSION)/submodules
+QT5_SITE = https://download.qt.io/archive/qt/$(QT5_VERSION_MAJOR)/$(QT5_VERSION)/submodules
 
 include $(sort $(wildcard package/qt5/*/*.mk))