Upgrade classpath version and fix compilation
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 15 Jun 2009 18:46:43 +0000 (20:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 15 Jun 2009 18:48:50 +0000 (20:48 +0200)
 * Upgrade to version 0.98
 * Use --disable-Werror, otherwise it doesn't build since warnings are
   treated as errors
 * Don't depend on tiff, which isn't mandatory, and doesn't
   build. Once tiff is fixed, we can re-add it as a dependency.

package/java/classpath/classpath.mk

index faa6341434a00a400944b45fac133fb6b2eb357f..71c18a045c7557c3b195911dc9bbb2e56d4dbf4c 100644 (file)
@@ -3,7 +3,7 @@
 # classpath 0.96.1
 #
 #############################################################
-CLASSPATH_VERSION = 0.97.1
+CLASSPATH_VERSION = 0.98
 CLASSPATH_SOURCE = classpath-$(CLASSPATH_VERSION).tar.gz
 CLASSPATH_SITE = $(BR2_GNU_MIRROR)/classpath
 CLASSPATH_AUTORECONF = NO
@@ -51,9 +51,10 @@ CLASSPATH_CONF_OPT = \
                --enable-static \
                --disable-glibtest --enable-explicit-deps=no \
                --disable-debug \
-               --disable-gconf-peer --disable-examples --disable-plugin
+               --disable-gconf-peer --disable-examples --disable-plugin \
+               --disable-Werror
 
-CLASSPATH_DEPENDENCIES = uclibc host-pkgconfig libpng jpeg tiff
+CLASSPATH_DEPENDENCIES = uclibc host-pkgconfig libpng jpeg
 
 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
        CLASSPATH_DEPENDENCIES+= alsa-lib