glibc: add 2.19 as a supported version
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 Feb 2014 17:43:46 +0000 (18:43 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 13 Feb 2014 21:22:54 +0000 (22:22 +0100)
glibc 2.19 has been released recently
(https://sourceware.org/ml/libc-alpha/2014-02/msg00224.html). This
commit allows to build a toolchain with this new version. In order to
allow this, we add a version selection that did not exist for
glibc. We default to 2.18, which was the only supported version until
now, and add an option for 2.19.

For microblaze, which uses a specific glibc version, the version
selection choice is not displayed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/glibc/Config.in [new file with mode: 0644]
package/glibc/glibc.mk
toolchain/toolchain-buildroot/Config.in

diff --git a/package/glibc/Config.in b/package/glibc/Config.in
new file mode 100644 (file)
index 0000000..a92b5ea
--- /dev/null
@@ -0,0 +1,21 @@
+if BR2_TOOLCHAIN_BUILDROOT_GLIBC
+
+choice
+       prompt "glibc version"
+       default BR2_GLIBC_VERSION_2_18
+       # Architectures supported in mainline glibc
+       depends on BR2_arm    || BR2_armeb    || BR2_aarch64 || \
+                  BR2_i386   || BR2_mips     || BR2_mipsel  || \
+                  BR2_mips64 || BR2_mips64el || BR2_powerpc || \
+                  BR2_sh     || BR2_sh64     || BR2_sparc   || \
+                  BR2_x86_64
+
+config BR2_GLIBC_VERSION_2_18
+       bool "2.18"
+
+config BR2_GLIBC_VERSION_2_19
+       bool "2.19"
+
+endchoice
+
+endif
index 96de02a75403dfe1846c765e33c5177b77970a46..89eaaf6de5b10d1b2724e2186c578d2bd7747652 100644 (file)
@@ -21,7 +21,7 @@ GLIBC_SITE = http://downloads.yoctoproject.org/releases/eglibc/
 GLIBC_SOURCE = eglibc-$(GLIBC_VERSION).tar.bz2
 GLIBC_SRC_SUBDIR = libc
 else
-GLIBC_VERSION = 2.18
+GLIBC_VERSION = $(if $(BR2_GLIBC_VERSION_2_19),2.19,2.18)
 GLIBC_SITE = $(BR2_GNU_MIRROR)/libc
 GLIBC_SOURCE = glibc-$(GLIBC_VERSION).tar.xz
 GLIBC_SRC_SUBDIR = .
index cd88889c4ae383c21fe7992db112cd05c7629a4e..eb5ee4644a97278ac59c094114c34ec370b9dd4d 100644 (file)
@@ -70,7 +70,7 @@ config BR2_TOOLCHAIN_BUILDROOT_LIBC
        default "glibc"  if BR2_TOOLCHAIN_BUILDROOT_GLIBC
 
 source "package/uclibc/Config.in"
-
+source "package/glibc/Config.in"
 source "package/binutils/Config.in.host"
 source "package/gcc/Config.in.host"
 source "package/elf2flt/Config.in.host"