package/quota: add optional openldap dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 1 Apr 2019 17:13:11 +0000 (19:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 1 Apr 2019 20:48:16 +0000 (22:48 +0200)
Don't enable openldap in static build because openldap has too many
optional dependencies (gmp, gnutls, nss, openssl, ...) and openldap
doesn't provide a pkg-config file (and does not want to do it:
http://www.openldap.org/lists/openldap-bugs/201406/msg00020.html)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/quota/quota.mk

index 836baf607150534e382abfb0f7fcb2b916984c12..e356d91a061565ceeb3b62204c2d383ec1dc37fe 100644 (file)
@@ -29,6 +29,13 @@ ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
 QUOTA_DEPENDENCIES += libtirpc host-pkgconf
 endif
 
+ifeq ($(BR2_PACKAGE_OPENLDAP):$(BR2_STATIC_LIBS),y:)
+QUOTA_DEPENDENCIES += openldap
+QUOTA_CONF_OPTS += --enable-ldapmail
+else
+QUOTA_CONF_OPTS += --disable-ldapmail
+endif
+
 QUOTA_CONF_ENV = LIBS="$(QUOTA_LIBS)"
 
 $(eval $(autotools-package))