util-linux: fix host build when ncurses is not installed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Oct 2016 10:18:00 +0000 (12:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Oct 2016 10:18:00 +0000 (12:18 +0200)
lib/colors.c uses HAVE_LIBTINFO to decide whether term.h and ncurses.h
should be included. However, the configure.ac check is bogus: it
checks for tinfo using pkg-config, and then if it fails, checks with
AC_CHECK_LIB(). So, if you have tinfo installed, but not the
corresponding development package, the pkg-config test will fail, but
the AC_CHECK_LIB test will succeed, even though the headers are not
available.

To address this, we explicitly tell host-util-linux that tinfo is not
available, like we're already doing for ncurses.

Fixes:

  http://autobuild.buildroot.net/results/3c447e601a7b728860e78cabf2191ab206e6480d/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/util-linux.mk

index bd6508ce4485c602b82ea47431d5f6183a51bf6a..cf03fd44ac58c58a231120677c0bfd60929afba3 100644 (file)
@@ -133,7 +133,8 @@ HOST_UTIL_LINUX_CONF_OPTS += \
        --enable-libblkid \
        --enable-libmount \
        --enable-libuuid \
-       --without-ncurses
+       --without-ncurses \
+       --without-tinfo
 
 ifeq ($(BR2_PACKAGE_HOST_UTIL_LINUX),y)
 HOST_UTIL_LINUX_CONF_OPTS += --disable-makeinstall-chown