Makefile: build all manuals in $(O)/docs/manual
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Oct 2011 05:52:03 +0000 (07:52 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Oct 2011 05:52:03 +0000 (07:52 +0200)
Like Arnouts' patch originally did.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index d95aa3a2783bb6bc4c0a0c9e8f0ef54b9a7e6137..80ca587ab2b7e4d85764b01790cce01a81134605 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -716,19 +716,13 @@ release:
 define GENDOC_INNER
 $(1): $(1)-$(3)
 .PHONY: $(1)-$(3)
-$(1)-$(3): $$(O)/docs/$(1)/$(2)/$(1).$(4)
+$(1)-$(3): $$(O)/docs/$(1)/$(1).$(4)
 
-$$(O)/docs/$(1)/$(2)/$(1).$(4): docs/$(1)/$(1).txt $$($(call UPPERCASE,$(1))_SOURCES)
+$$(O)/docs/$(1)/$(1).$(4): docs/$(1)/$(1).txt $$($(call UPPERCASE,$(1))_SOURCES)
        @echo "Generating $(5) $(1)..."
        $(Q)mkdir -p $$(O)/docs/$(1)/$(2)
        $(Q)a2x $(6) -f $(2) -d book -L -r $(TOPDIR)/docs/images \
          -D $$(@D) $$<
-
-clean-$(1): clean-$(1)-$(3)
-.PHONY: clean-$(1)-$(3)
-clean-$(1)-$(3):
-       $(Q)$(RM) -rf $(O)/docs/$(1)/$(2)
-
 endef
 
 ################################################################################
@@ -746,6 +740,8 @@ $(call GENDOC_INNER,$(1),pdf,pdf,pdf,PDF,--dblatex-opts "-P latex.output.revhist
 $(call GENDOC_INNER,$(1),text,txt,text,Text)
 $(call GENDOC_INNER,$(1),epub,epub,epub,EPUB)
 clean: clean-$(1)
+clean-$(1):
+       $(Q)$(RM) -rf $(O)/docs/$(1)
 .PHONY: $(1) clean-$(1)
 endef