package/lldpd: add libcap optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 7 Apr 2019 19:58:33 +0000 (21:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Apr 2019 17:31:55 +0000 (19:31 +0200)
libcap optional dependency has been added in version 1.0.2 with
https://github.com/vincentbernat/lldpd/commit/f6933edaf2edea12ef72ef7c70958c2a617f6a1f

Also refactor check and valgrind optional dependencies to put them on a
single line

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lldpd/lldpd.mk

index 99de40d498e75e4b6141194b7a03cb5beaa54198..86c825c4e160e0a7f305fe7aa62f748b2e90ffa5 100644 (file)
@@ -6,18 +6,15 @@
 
 LLDPD_VERSION = 1.0.3
 LLDPD_SITE = http://media.luffy.cx/files/lldpd
-LLDPD_DEPENDENCIES = host-pkgconf libevent
+LLDPD_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_CHECK),check) \
+       host-pkgconf \
+       $(if $(BR2_PACKAGE_LIBCAP),libcap) \
+       libevent \
+       $(if $(BR2_PACKAGE_VALGRIND),valgrind)
 LLDPD_LICENSE = ISC
 LLDPD_LICENSE_FILES = LICENSE
 
-ifeq ($(BR2_PACKAGE_CHECK),y)
-LLDPD_DEPENDENCIES += check
-endif
-
-ifeq ($(BR2_PACKAGE_VALGRIND),y)
-LLDPD_DEPENDENCIES += valgrind
-endif
-
 # Detection of c99 support in configure fails without WCHAR. To enable
 # automatic detection of c99 support by configure, we need to enable
 # WCHAR in toolchain. But actually we do not need WCHAR at lldpd