package/libarchive: add optional support for bzip2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 14:29:54 +0000 (15:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2016 14:50:38 +0000 (15:50 +0100)
When bzip2 was compiled before, libarchive will use it as optional
dependency:

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/lib/libarchive.so.13.1.2 | grep NEEDED
 0x00000001 (NEEDED)                     Shared library: [liblzma.so.5]
 0x00000001 (NEEDED)                     Shared library: [libbz2.so.1.0]
 0x00000001 (NEEDED)                     Shared library: [libz.so.1]
 0x00000001 (NEEDED)                     Shared library: [libc.so.1]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libarchive/libarchive.mk

index 206de3f58d77d08d909525021794934daca1ef02..726142b217daf11b3a531bf9b5bdd3c9eeb93a9d 100644 (file)
@@ -42,6 +42,13 @@ else
 LIBARCHIVE_CONF_OPTS += --disable-xattr
 endif
 
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+LIBARCHIVE_CONF_OPTS += --with-bz2lib
+LIBARCHIVE_DEPENDENCIES += bzip2
+else
+LIBARCHIVE_CONF_OPTS += --without-bz2lib
+endif
+
 ifeq ($(BR2_PACKAGE_EXPAT),y)
 LIBARCHIVE_DEPENDENCIES += expat
 else