projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fac43bd
)
cups: add optional image dependencies
author
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 1 May 2012 12:13:01 +0000
(14:13 +0200)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 1 May 2012 12:13:01 +0000
(14:13 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cups/cups.mk
patch
|
blob
|
history
diff --git
a/package/cups/cups.mk
b/package/cups/cups.mk
index 1508b6ee0aac15bb38333bbb1a1155bc6f451b19..f06502ab271877d8676340a276a7872e2deb60ef 100644
(file)
--- a/
package/cups/cups.mk
+++ b/
package/cups/cups.mk
@@
-15,6
+15,11
@@
CUPS_CONF_OPT = --without-perl \
--disable-gnutls \
--disable-gssapi
+CUPS_DEPENDENCIES = $(if $(BR2_PACKAGE_ZLIB),zlib) \
+ $(if $(BR2_PACKAGE_LIBPNG),libpng) \
+ $(if $(BR2_PACKAGE_JPEG),jpeg) \
+ $(if $(BR2_PACKAGE_TIFF),tiff)
+
ifeq ($(BR2_PACKAGE_DBUS),y)
CUPS_CONF_OPT += --enable-dbus
CUPS_DEPENDENCIES += dbus