toolchain-external: remove ARM CodeSourcery 2009q3
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 14:54:43 +0000 (16:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 15:17:03 +0000 (17:17 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 835763adb3c5f050d11f6bda65063d72c4c4f391..3b1d792c4c7ea855bb26fae9f4d844a6d75ca41d 100644 (file)
@@ -161,27 +161,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
               Select BR2_SOFT_FLOAT
               Set BR2_TARGET_OPTIMIZATION to -mthumb
 
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2009Q3
-       bool "Sourcery CodeBench ARM 2009q3"
-       depends on BR2_arm
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_INSTALL_LIBSTDCPP
-       help
-         Sourcery CodeBench toolchain for the ARM architecture, from
-         Mentor Graphics. It uses gcc 4.4.1, binutils 2.19, glibc
-         2.10 and gdb 6.8 and kernel headers 2.6.30. It has support
-         for the following variants:
-           - ARMv5T, little endian, soft-float, glibc
-             Select ARM926T, ARM10T, XScale or another ARMv5 core
-             Select BR2_SOFT_FLOAT
-           - ARMv4T, little endian, soft-float, glibc
-             Select ARM720T, ARM920T, ARM922T or another ARMv4 core
-             Select BR2_SOFT_FLOAT
-           - ARMv7-A, Thumb 2, little endian, soft-float, glibc
-             Select Cortex-A8, Cortex-A9 or another ARMv7-A core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -mthumb
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
        bool "Sourcery CodeBench MIPS 2011.03"
        depends on BR2_mips || BR2_mipsel
@@ -553,7 +532,6 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-linux-gnueabi"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_04
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_06
-       default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2009Q3
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
index 35fcb7b978a323024058f80eeed32f9000d25532..14804d6088e08f44e9a8d3a6fdc85d887ca5a675 100644 (file)
@@ -175,10 +175,7 @@ ifeq ($(BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD),y)
 TOOLCHAIN_EXTERNAL_DEPENDENCIES = $(TOOLCHAIN_EXTERNAL_DIR)/.extracted
 endif
 
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2009Q3),y)
-TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/arm/portal/package5383/public/arm-none-linux-gnueabi/
-TOOLCHAIN_EXTERNAL_SOURCE=arm-2009q3-67-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1),y)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/arm/portal/package6488/public/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2010q1-202-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009),y)