infra: fix "<pkg>-rebuild" when using rsync source feature
authorFabio Porcedda <fabio.porcedda@gmail.com>
Mon, 30 Jun 2014 09:51:28 +0000 (11:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 20:45:21 +0000 (22:45 +0200)
Because the configure stamp file depends on the rsync stamp file,
removing it by the "<pkg>-clean-for-rebuild" rule trigger the configure
step. To avoid triggering the configure step use an order-only dependency.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Reported-by: Cédric Marie <cedric.marie@openmailbox.org>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 2bd44660350045cd8035135bc5ca0e433498f716..395e593d24ac12e0cf6e598de5f391b730a6c3d4 100644 (file)
@@ -545,7 +545,10 @@ else
 #  source, by rsyncing
 #  depends
 #  configure
-$$($(2)_TARGET_CONFIGURE):     $$($(2)_TARGET_RSYNC)
+
+# Use an order-only dependency so the "<pkg>-clean-for-rebuild" rule
+# can remove the stamp file without triggering the configure step.
+$$($(2)_TARGET_CONFIGURE): | $$($(2)_TARGET_RSYNC)
 
 $(1)-depends:          $$($(2)_FINAL_DEPENDENCIES)