support: trivial fixes (typos and minor rewording) in gen-manual-lists.py
authorSamuel Martin <s.martin49@gmail.com>
Fri, 18 Oct 2013 20:31:27 +0000 (22:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Nov 2013 15:59:12 +0000 (16:59 +0100)
[Thomas: added Thomas DS Acked-by, given at
http://patchwork.ozlabs.org/patch/284719/, and made the additional
typo fixes suggested by Thomas DS.]

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
support/scripts/gen-manual-lists.py

index 35688430e6f213cf50572d03ad17f19fffb301da..4546e076569f4414127a2efdd5e300895d61fae8 100755 (executable)
@@ -88,7 +88,7 @@ def get_symbol_subset(root, filter_func):
 
 
 def get_symbol_parents(item, root=None, enable_choice=False):
-    """ Return the list of the item's parents. The lasst item of the list is
+    """ Return the list of the item's parents. The last item of the list is
     the closest parent, the first the furthest.
 
     :param item:          Item from which the the parent list is generated
@@ -107,7 +107,7 @@ def get_symbol_parents(item, root=None, enable_choice=False):
         parent = parent.get_parent()
     if isinstance(root, kconfiglib.Menu) or \
             (enable_choice and isinstance(root, kconfiglib.Choice)):
-        parents.append("") # Dummy empty parrent to get a leading arrow ->
+        parents.append("") # Dummy empty parent to get a leading arrow ->
     parents.reverse()
     return parents
 
@@ -126,15 +126,14 @@ def format_asciidoc_table(root, get_label_func, filter_func=lambda x: True,
     :param sub_menu:       Output the column with the sub-menu path
 
     """
-    def _format_entry(label, parents, sub_menu):
+    def _format_entry(item, parents, sub_menu):
         """ Format an asciidoc table entry.
 
         """
         if sub_menu:
-            return "| {0:<40} <| {1}\n".format(label, " -> ".join(parents))
+            return "| {0:<40} <| {1}\n".format(item, " -> ".join(parents))
         else:
-            return "| {0:<40}\n".format(label)
-
+            return "| {0:<40}\n".format(item)
     lines = []
     for item in get_symbol_subset(root, filter_func):
         if not item.is_symbol() or not item.prompts:
@@ -264,9 +263,9 @@ class Buildroot:
         # Implementation details:
         #
         # * The package list is generated from the *.mk file existence, the
-        #   first time this function is called. Despite the memory consumtion,
+        #   first time this function is called. Despite the memory consumption,
         #   this list is stored because the execution time of this script is
-        #   noticebly shorter than re-scannig the package sub-tree for each
+        #   noticeably shorter than rescanning the package sub-tree for each
         #   symbol.
         if not hasattr(self, "_package_list"):
             pkg_list = []