Revert "gst1-imx: fix v4l2 plugins disable options"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Nov 2017 20:28:48 +0000 (21:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Nov 2017 20:28:48 +0000 (21:28 +0100)
This reverts commit 56b611a972218e33e9fc4b48399138889a688a8e. This
patch was intended for the next branch, not the master branch.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-imx/Config.in
package/gstreamer1/gst1-imx/gst1-imx.mk

index 9b977bdde8b90cb3689048d50bdc784742d6f657..9f792d1c82cb14b0811f3b4021b0141f4570f49e 100644 (file)
@@ -84,10 +84,4 @@ config BR2_PACKAGE_GST1_IMX_V4L2VIDEOSRC
        help
          Elements for V4L2 capture
 
-config BR2_PACKAGE_GST1_IMX_V4L2VIDEOSINK
-       bool "imxv4l2videosink"
-       select BR2_PACKAGE_GST1_PLUGINS_BAD
-       help
-         Elements for V4L2 output
-
 endif
index 080fce5458da86b73be52a645d01bb0b46b52c02..a21e2829bed5760e16e6d1c642ff3022f4d49334 100644 (file)
@@ -83,17 +83,10 @@ GST1_IMX_CONF_OPTS += --disable-vpu
 endif
 
 ifeq ($(BR2_PACKAGE_GST1_IMX_V4L2VIDEOSRC),y)
-# There's no --enable-imxv4l2videosrc option
+# There's no --enable-v4l2src option
 GST1_IMX_DEPENDENCIES += gst1-plugins-bad
 else
-GST1_IMX_CONF_OPTS += --disable-imxv4l2videosrc
-endif
-
-ifeq ($(BR2_PACKAGE_GST1_IMX_V4L2VIDEOSINK),y)
-# There's no --enable-imxv4l2videosink option
-GST1_IMX_DEPENDENCIES += gst1-plugins-bad
-else
-GST1_IMX_CONF_OPTS += --disable-imxv4l2videosink
+GST1_IMX_CONF_OPTS += --disable-v4l2src
 endif
 
 $(eval $(waf-package))