libtool: don't error on missing directories in clean targets
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Sep 2008 08:11:02 +0000 (08:11 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Sep 2008 08:11:02 +0000 (08:11 -0000)
package/libtool/libtool.mk

index 20b300a8d2e6ef416f8965fe913a42898bc78f87..238bfa6f837566f22b81e14d4c66a9df2b27283c 100644 (file)
@@ -90,7 +90,7 @@ endif
 libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)
 
 libtool-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LIBTOOL_DIR) uninstall
+       -$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LIBTOOL_DIR) uninstall
        -$(MAKE) -C $(LIBTOOL_DIR) clean
 
 libtool-cross: uclibc $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
@@ -138,7 +138,7 @@ endif
 host-libtool: $(LIBTOOL)
 
 host-libtool-clean:
-       $(MAKE) -C $(LIBTOOL_HOST_DIR) uninstall
+       -$(MAKE) -C $(LIBTOOL_HOST_DIR) uninstall
        -$(MAKE) -C $(LIBTOOL_HOST_DIR) clean
 
 host-libtool-dirclean: