linux: add note about why it's safe to include other .mk files
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 13 Mar 2015 18:57:28 +0000 (19:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 13 Mar 2015 21:04:29 +0000 (22:04 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 5afcd4e7896f935a9ba76f91d658ec8a35c57e16..b1aca419da85eed3f138c7050b9ab97445659826 100644 (file)
@@ -323,6 +323,14 @@ define LINUX_INSTALL_TARGET_CMDS
        $(LINUX_INSTALL_HOST_TOOLS)
 endef
 
+# Note: our package infrastructure uses the full-path of the last-scanned
+# Makefile to determine what package we're currently defining, using the
+# last directory component in the path. As such, including other Makefile,
+# like below, before we call one of the *-package macro is usally not
+# working.
+# However, since the files we include here are in the same directory as
+# the current Makefile, we are OK. But this is a hard requirement: files
+# included here *must* be in the same directory!
 include $(sort $(wildcard linux/linux-ext-*.mk))
 
 $(eval $(kconfig-package))