Revert "package/qt5base: provide "qt.conf" to make "qmake" relocatable"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Jul 2017 09:28:23 +0000 (11:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Jul 2017 09:28:23 +0000 (11:28 +0200)
This reverts commit a2efb84dec42608e46860a24c31db5a4588edd1e, as it
causes files to be installed in an invalid location, causing build
failures.

Fixes:

  http://autobuild.buildroot.net/results/a1a9eeb7fec07a2f9f0d05e6c1900ad7cffb6656/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5base/qt.conf.in [deleted file]
package/qt5/qt5base/qt5base.mk

diff --git a/package/qt5/qt5base/qt.conf.in b/package/qt5/qt5base/qt.conf.in
deleted file mode 100644 (file)
index 48e4b92..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-[Paths]
-Prefix=@@HOST_DIR@@/usr
-Sysroot=@@STAGING_DIR@@
-Headers=/usr/include/qt5
-Plugins=/usr/lib/qt/plugins
-Examples=/usr/lib/qt/examples
index 3e55002264d0ba4bc25aa465a7efb6964ba9c1ac..5fe8bb884b324372523bb1abe126d521138587d7 100644 (file)
@@ -258,17 +258,9 @@ define QT5BASE_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef
 
-# The file "qt.conf" can be used to override the hard-coded paths that are
-# compiled into the Qt library. We need it to make "qmake" relocatable.
-define QT5BASE_INSTALL_QT_CONF
-       sed -e "s|@@HOST_DIR@@|$(HOST_DIR)|" -e "s|@@STAGING_DIR@@|$(STAGING_DIR)|" \
-               $(QT5BASE_PKGDIR)/qt.conf.in > $(HOST_DIR)/usr/bin/qt.conf
-endef
-
 define QT5BASE_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
        $(QT5_LA_PRL_FILES_FIXUP)
-       $(QT5BASE_INSTALL_QT_CONF)
 endef
 
 define QT5BASE_INSTALL_TARGET_LIBS